1. Home
  2. Server
  3. The server is unreachable - Desktops & Laptops - Plex Forum

The server is unreachable - Desktops & Laptops - Plex Forum

Rsdaa 12/11/2021 465

Some feedback

That is not an issue. It was decided when custom server access url feature was implemented, that it would be flagged as local="0". It has no consequence

These repeated errors show an issue with communications with the plex.tv pubsub servers. These are used for getting connectivity test results for remote access as well as establishing if there is an internet connection or not (needed for Premium Music Libraries scanning).

Oct 19, 2018 12:42:51.261 [0x7fec32bfe700] ERROR - EventSource: Retrying in 15 seconds.Oct 19, 2018 12:43:06.261 [0x7fec32bfe700] DEBUG - EventSource: Resolving 172.104.133.220 port 443sOct 19, 2018 12:43:06.262 [0x7fec32bfe700] DEBUG - EventSource: Resolved 172.104.133.220 to 172.104.133.220Oct 19, 2018 12:43:06.359 [0x7fec32bfe700] DEBUG - EventSource: Connected in 67 ms.Oct 19, 2018 12:43:06.360 [0x7fec32bfe700] DEBUG - EventSource: Wrote data, reading reply.Oct 19, 2018 12:43:06.505 [0x7fec333ff700] DEBUG - EventSource: Read HTTP reply header.Oct 19, 2018 12:45:02.332 [0x7fec333ff700] DEBUG - EventSource: Successfully connected to 172.104.133.220.Oct 19, 2018 12:45:02.332 [0x7fec333ff700] DEBUG - EventSource: Failure in IdleTimeout (0 - Success).Oct 19, 2018 12:45:02.332 [0x7fec333ff700] ERROR - EventSource: Retrying in 15 seconds.Oct 19, 2018 12:45:17.333 [0x7fec32bfe700] DEBUG - EventSource: Resolving 172.104.133.220 port 443sOct 19, 2018 12:45:17.333 [0x7fec32bfe700] DEBUG - EventSource: Resolved 172.104.133.220 to 172.104.133.220Oct 19, 2018 12:45:17.434 [0x7fec32bfe700] DEBUG - EventSource: Connected in 69 ms.Oct 19, 2018 12:45:17.434 [0x7fec32bfe700] DEBUG - EventSource: Wrote data, reading reply.Oct 19, 2018 12:45:17.577 [0x7fec333ff700] DEBUG - EventSource: Read HTTP reply header.Oct 19, 2018 12:47:13.404 [0x7fec333ff700] DEBUG - EventSource: Successfully connected to 172.104.133.220.Oct 19, 2018 12:47:13.404 [0x7fec333ff700] DEBUG - EventSource: Failure in IdleTimeout (0 - Success).Oct 19, 2018 12:47:13.404 [0x7fec333ff700] ERROR - EventSource: Retrying in 15 seconds.Oct 19, 2018 12:47:28.404 [0x7fec333ff700] DEBUG - EventSource: Resolving 172.104.133.220 port 443sOct 19, 2018 12:47:28.405 [0x7fec333ff700] DEBUG - EventSource: Resolved 172.104.133.220 to 172.104.133.220Oct 19, 2018 12:47:28.504 [0x7fec32bfe700] DEBUG - EventSource: Connected in 68 ms.Oct 19, 2018 12:47:28.505 [0x7fec32bfe700] DEBUG - EventSource: Wrote data, reading reply.Oct 19, 2018 12:47:28.644 [0x7fec333ff700] DEBUG - EventSource: Read HTTP reply header.

There is also some evidence of delayed or lost events from this pubsub server

Oct 18, 2018 18:10:22.851 [0x7fec28ffd700] DEBUG - HTTP requesting POST https://plex.tv/servers.xml?auth_token=xxxxxxxxxxxxxxxxxxxx&async=1&asyncIdentifier=878e7d6f-b4fa-44fc-b9b2-f49a88e01e51Oct 18, 2018 18:10:23.338 [0x7fec28ffd700] DEBUG - HTTP 201 response from POST https://plex.tv/servers.xml?auth_token=xxxxxxxxxxxxxxxxxxxx&async=1&asyncIdentifier=878e7d6f-b4fa-44fc-b9b2-f49a88e01e51Oct 18, 2018 18:10:23.639 [0x7fec28ffd700] DEBUG - Request: [34.245.172.51:52300 (WAN)] GET /identity (7 live) TLS Signed-in Token (Szajkop)Oct 18, 2018 18:10:23.641 [0x7fec333ff700] DEBUG - Completed: [34.245.172.51:52300] 200 GET /identity (7 live) TLS 1ms 357 bytesOct 18, 2018 18:12:33.916 [0x7fec333ff700] DEBUG - EventSource: Got event [data] ''

The above shows a connectivity test was carried out immediately and was successful - but the event was not received till over 2 minutes larer.

Oct 19, 2018 10:02:23.829 [0x7fec0dffa700] DEBUG - HTTP requesting PUT https://plex.tv/api/servers/de1a8ec35b7f4e221e1748797b4ee2cfa0f26347/connectivity?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&asyncIdentifier=2d03945a-7b4c-4aed-9c0e-229c2f47b9bcOct 19, 2018 10:02:24.242 [0x7fec0dffa700] DEBUG - HTTP 200 response from PUT https://plex.tv/api/servers/de1a8ec35b7f4e221e1748797b4ee2cfa0f26347/connectivity?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&asyncIdentifier=2d03945a-7b4c-4aed-9c0e-229c2f47b9bcOct 19, 2018 10:02:24.435 [0x7fec08ff0700] DEBUG - Request: [34.241.199.208:37524 (WAN)] GET /identity (12 live) TLS Signed-in Token (Szajkop)Oct 19, 2018 10:02:24.437 [0x7fec333ff700] DEBUG - Completed: [34.241.199.208:37524] 200 GET /identity (12 live) TLS 1ms 357 bytes

The above shows a connectivity test made immediately when requested - but no event was received

Oct 19, 2018 10:12:12.728 [0x7fec19bff700] DEBUG - HTTP requesting PUT https://plex.tv/api/servers/de1a8ec35b7f4e221e1748797b4ee2cfa0f26347/connectivity?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&asyncIdentifier=7c7fb4ad-a1c5-443d-9395-28ffcd7664bcOct 19, 2018 10:12:12.985 [0x7fec19bff700] DEBUG - HTTP 200 response from PUT https://plex.tv/api/servers/de1a8ec35b7f4e221e1748797b4ee2cfa0f26347/connectivity?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&asyncIdentifier=7c7fb4ad-a1c5-443d-9395-28ffcd7664bcOct 19, 2018 10:12:13.167 [0x7fec28ffd700] DEBUG - Request: [52.49.250.227:47634 (WAN)] GET /identity (16 live) TLS Signed-in Token (Szajkop)Oct 19, 2018 10:12:13.168 [0x7fec333ff700] DEBUG - Completed: [52.49.250.227:47634] 200 GET /identity (16 live) TLS 1ms 357 bytesOct 19, 2018 10:14:18.367 [0x7fec32bfe700] DEBUG - EventSource: Got event [data] ''

The above is similar to the first one, a delay of over 2 minutes in getting the event.

Possible causes:

use of security of filters that may be blocking some IP Addressesvpn/proxy intercepting some communicationsan actual issue with the pubsub server the PMS is using (pubsub server with IP address 172.104.133.220)- the 2 minute delays suggests that there may have been an issue here

We can try and see if a different one gets picked up by deleting references to this pubsub server (172.104.133.220) and restarting PMS and see if it switches to a different pubsub server. For each region there are a number of pubsub servers and selection would be of fastest

To do this, shutdown Plex Media Server and carefully edit Preferences.xml to delete these items

PubSubServerPubSubServerPingPubSubServerRegion

Then restart Plex Media Server

and as @ChuckPa suggested - do try without the custom server access url. I did a quick test adding a custom server access url to one of my servers and it worked fine from Plex web on another machine.


PREV: Apache Config: .htaccess or Virtual Hosts? | LornaJane

NEXT: Htaccess - HTTPD - Apache Software Foundation

Popular Articles

Hot Articles
Back to Top