1. Home
  2. VPS
  3. centos6 - Cannot Connect CentOS VM to Internet (NAT ...

centos6 - Cannot Connect CentOS VM to Internet (NAT ...

Rsdaa 07/02/2022 175

So after fighting the VMWare network giant for the past day, I decided to give in and ask for help.I have a CentOS 6 image running on Windows 7 using a NAT on VMWare Workstation 8.0.2 build-591240, and for some reason, I can no longer connect to the internet with a static IP address. This seems to only to apply to static, and not DHCP, which tells me it's either: some program on my Windows 7 OS that's blocking the connection for that IP address, or there's something weird that happened to my configuration on theCentOS image.

I didn't know if this was due to a yum update, so I tried reinstalling VMWare tools.This didn't seem to fix the issue.I've also tried the following:

Made sure the VMnet connection was connected (stupid, but had to check... also I can connect to the internet with DHCP)Made sure my firewall on Windows allowed for VMware to connect to the internetI've seen/read that Windows sometimes blocks ping requests, so I tried going to www.google.com in Firefox, this got a "Server not found response"... so do I have to do something different for DNS??I checked the registry of my Windows machine, I only have 1 entry for a default gateway

Like I said, this seemed to happen out of the blue.The image could connect to the internet before with no issue.Is anyone aware of a CentOS update that might cause this? I've added my configuration below to save some debugging cycles:

[root@MyCentOS ~]# ifconfigeth0Link encap:EthernetHWaddr 00:0C:29:A0:51:BDinet addr:192.168.88.128Bcast:192.168.88.255Mask:255.255.255.0UP BROADCAST RUNNING MULTICASTMTU:1500Metric:1RX packets:683 errors:0 dropped:0 overruns:0 frame:0TX packets:67 errors:0 dropped:0 overruns:0 carrier:0collisions:0 txqueuelen:1000RX bytes:64242 (62.7 KiB)TX bytes:8055 (7.8 KiB)loLink encap:Local Loopbackinet addr:127.0.0.1Mask:255.0.0.0UP LOOPBACK RUNNINGMTU:16436Metric:1RX packets:1049 errors:0 dropped:0 overruns:0 frame:0TX packets:1049 errors:0 dropped:0 overruns:0 carrier:0collisions:0 txqueuelen:0RX bytes:68417 (66.8 KiB)TX bytes:68417 (66.8 KiB)[root@MyCentOS ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0DEVICE="eth0"BOOTPROTO="static"IPV6INIT="no"NM_CONTROLLED="no"ONBOOT="yes"IPADDR=192.168.88.128NETMASK=255.255.255.0GATEWAY=192.168.88.2TYPE="Ethernet"[root@MyCentOS ~]# cat /etc/sysconfig/networkNETWORKING=yesHOSTNAME=MyCentOSGATEWAY=192.168.88.2[root@MyCentOS ~]# service iptables statusiptables: Firewall is not running.[root@MyCentOS ~]# service ip6tables statusip6tables: Firewall is not running.[root@MyCentOS ~]# cat /etc/selinux/config# This file controls the state of SELinux on the system.# SELINUX= can take one of these three values:# enforcing - SELinux security policy is enforced.# permissive - SELinux prints warnings instead of enforcing.# disabled - No SELinux policy is loaded.SELINUX=disabled# SELINUXTYPE= can take one of these two values:# targeted - Targeted processes are protected,# mls - Multi Level Security protection.SELINUXTYPE=targeted[root@MyCentOS ~]# ping 192.168.88.2PING 192.168.88.2 (192.168.88.2) 56(84) bytes of data.64 bytes from 192.168.88.2: icmp_seq=1 ttl=128 time=0.391 ms64 bytes from 192.168.88.2: icmp_seq=2 ttl=128 time=0.271 ms^C--- 192.168.88.2 ping statistics ---2 packets transmitted, 2 received, 0% packet loss, time 1349msrtt min/avg/max/mdev = 0.271/0.331/0.391/0.060 ms[root@MyCentOS ~]# ping www.google.comping: unknown host www.google.com[root@MyCentOS ~]# uname -aLinux MyCentOS 2.6.32-431.3.1.el6.x86_64 #1 SMP Fri Jan 3 21:39:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux[root@MyCentOS ~]# vmware-toolbox-cmd -v8.8.2.10499 (build-590212)

PREV: Configure PS4 Proxy Server | Best PS4 Proxy Server 2021

NEXT: can't connect to oculus server 2020 - Flavio Filho

Popular Articles

Hot Articles
Back to Top